Wpis z mikrobloga

@mat53: bo to są ustawienia sieci NAT, virtualbox tworzy połączenie NAT do internetu i drugie dla komunikacji między VMkami, on dał po prostu losowe screeny bo nie wie chyba do końca co robi, domyslnie adresy NAT są z 10.x.x.x
@bruuh Jesli chce, żeby virtualki miały dostęp do netu, to powinien zmienić ustawienia sieci NAT (np na 0.0.0.0/0), czy problem jest zupełnie gdzie indziej? (przy okazji, certyfikowany architekt aws na poziomie associate here, nie mam pojecia jakim cudem dali mi ten cert :D)
@mat53: jak zobaczysz na tym screenie masz zakładki karta 1, karta 2 itp. no to na jednej niech ustawi sieć wewnętrzna a na drugiej NAT i powinno banglać, komputery za NATem każdy będzie w swojej podsieci bodajże virtualbox dla pierwszej VMki zrobi 10.0.2.X dla drugiej 10.0.3.X a te z sieci wewnętrznej dostaną IP z 192.168.0.X ale można to zrobić też na inne sposoby, poza tym problemów może być więcej bo czasem
  • 0
@bruuh: hej, dzięki za odpowiedź, faktycznie słabo się orientuje w tym co robie, w każdym razie dodałem im NATy ale dalej brak internetu
@l3cho: no to jeszcze mam taki pomysł że domyslny sie zrobił ten adapter z 192.xx
możesz to sprawdzić robiąc sudo ip route list
ten drugi możesz zrobić domyślnym przez sudo ip route add default via 10.0.3.1 dev enp0s8
obie maszyny dostały 10.0.3.15 według mnie dziwne ale nie wiem może tak ma być ( ͡° ͜ʖ ͡°) jak testujesz czy masz neta rób ping 1.1.1.1
btw. spróbuj jedną
@l3cho: to samo zrobić na drugiej maszynie
metric to "koszt" użycia danego połączenia dla systemu, czyli mówiąc po ludzku
system zawsze próbuje użyć połączenia z najmniejszym metric jako pierwszego

a tego 192.168.x.x powinien używac dlatego że masz taki default dla tego zakresu IP