Wpis z mikrobloga

Mam Raspberry Pi i chciałbym hostować u siebie prywatny serwerek jak i stronę.
Problem jest taki, że nie wiem jak to wszystko podłączyć, gdy router działa jako bridge. (tutaj opis mojej sieci).
Próbowałem to robić, ale okazało się, że mój dostawca udostępnia mi tylko prywatny adres IP, a z tego co czytałem to trzeba mieć publiczny (może ktoś mnie poprawić jeśli gadam głupoty? xD).
Jeśli to prawda to musiałbym ich prosić o zmianę adresu na publiczny?
Jak potem ustawić statyczny adres dla Rasberry jeśli nie mam dostępu do UI routera?
Czy cała ta struktura sieci byłaby w ogóle bezpieczna?
#siecikomputerowe #router #sieci #internet #rasberrypi
  • 8
Z praktyki to jak operator nie dał publicznego, to raczej go nie da i nic z tym nie zrobisz.
Na tym polegają całe oszczędności że na jednym publicznym jest podpięte całe osiedle.
Możesz sprawdzić tracert 8.8.8.8 i przekonać się ile się jak dużo sieci jest po drodze do bramy na internet.
@rysiek1337: Pytanie do operatora:
czy masz pub ip. i czy nie jesteś schowany za natem.
Jak nie jesteś schowany za natem to wtedy w ustawieniach Dasana w dziale port forwarding przekierowywujesz porty (dla http np. 80) i masz dostęp z zewnątrz.
@Marcin648:

1 <1 ms <1 ms <1 ms 192.168.1.XXX

2 2 ms 1 ms 1 ms ip-91.189.XXX.X.skyware.pl [91.189.XXX.X]

3 1 ms 1 ms 1 ms 172.16.11.113

4 2 ms 1 ms 1 ms 172.16.11.116

5 7 ms 7 ms 7 ms google.tpix.pl [195.149.232.62]

6 7 ms 7 ms 7 ms 108.170.250.193

7 7 ms 6 ms 7 ms 216.239.41.165

8 7 ms 7 ms 7 ms dns.google [8.8.8.8]


Trace complete.
@rysiek1337: Po co chcesz to robic, zeby dostep mieli wszyscy? Mozesz zrobic VPNA na jakims VPSie zeby kierowac ruch osob ktore znasz i maja potrzebny ten dostep.

Bezpiecznie bedzei jak sobie ustawic, jesli beda dziury na serwerze czy stronie jest to jakas furtka do grzebania w twojej sieci domowej.
@rysiek1337: Z tego trace'a wnioskuje że jednak masz za routerem publiczny adres. Czyli dostawca dostarcza publiczny adres. Kolega co też ma router DASAN'a mimo dobrej konfiguracji, przekierowanie portów też nie działa. Wydaje mi się że to dostawca blokuje po prostu otwieranie portów z jakiegoś powodu.